Java Agent 安装成功,没有数据

Jerry 发表于 2015年06月10日 15:11 最后修改于 2015年12月29日 18:36

故障说明

成功安装了 Java Agent,但是官网上无法看到性能数据。

故障原因

1、 如果您是在windows中使用的tomcat容器,请按以下方法解决:

(1)如果是在windows环境中使用安装版的tomcat,请参考tomcat手动安装方法:https://oneapm.kf5.com/posts/view/42173 ;

(2)如果是在windows环境中将tomcat注册成了服务,请参考windows下tomcat服务手动安装java探针:https://oneapm.kf5.com/posts/view/92800 ;

2、用户权限或者数据传输问题。

解决方案

第一步:确定 Agent 目录有权限访问;

第二步:确认服务器是否能连接外网,使用 ping tpm.oneapm.com 来检查。如果服务器不能连接外网,则agent不能将性能数据上传到oneapm云服务器;

第三步:telnet tpm.oneapm.com 443,检查数据传输端口是否打开。Windows 中显示空白则表示开启。Linux中显示 ' ^] '则表示开启;

第四步:校验 Agent 服务器的时间 date 是否与北京时间一致。如果不一致:主机为 Linux ,则用 ntpdate 命令同步服务器时钟,例如 ntpdate cn.pool.ntp.org;

第五步: 如果上述步骤都正常,修改OneAPM 目录下的 oneapm.properties 文件中 log_level 的变量为 finest,五分钟后将获取日志信息,修改OneAPM 目录下的 oneapm.properties 文件中 log_level 的变量为 off 关闭日志,提交给技术支持人员分析。

排查方案

Linux 下排查方法

[以Tomcat为例]

执行命令:

ps aux |grep oneapm

如果没有 OneAPM 进程,说明没有配置成功。

检查 Tomcat 目录 /bin/catalina.sh 下的文件配置

正确的配置方式如下:

BW_JAR=/full/path/to/oneapm.jar; export BW_JAR
CATALINA_OPTS="$CATALINA_OPTS -javaagent:$BW_JAR"; export CATALINA_OPTS

如果 OneAPM 和 JDK 在同一进程下

-> telnet tpm.oneapm.com 443 是否可正常访问

->检查 OneAPM 的 license_key 是否正确

->服务器的时区是否为东八区,时间是否为当前时间


Windows 下排查方法

[以Tomcat为例]

查看 OneAPM 有没有生成 logs 目录及 oneapm.log 文件

位置:/OneAPM/logs/oneapm.log

如果没有看到 logs 目录,说明没有配置成功

打开 Tomcat 下 /bin/catalina.bat

OneAPM 正确的配置方式如下:

set CATALINA_OPTS=%CATALINA_OPTS% -javaagent:"full/path/to/oneapm.jar"

备注:-javaagent:后面必须跟 oneapm.jar 的绝对路径。

如果有 logs 目录生成

dos 窗口输入-> telnet tpm.oneapm.com 443 是否可正常访问

->检查 OneAPM 的 license_key 是否正确

->服务器的时区是否为东八区,时间是否为当前时间



回复

ailandle发表于 2015年07月16日 16:41

时间  时区 不一至

王鹏OneAPM发表于 2015年10月26日 11:10

引用 ailandle 的回复

时间  时区 不一至

嗯 我这边改一下

您需要登录后才可以回复