Eclipse 安装 SDK 提示“The chosen operation is not currently available”

陈梦阳 发表于 2015年07月13日 18:33 最后修改于 2015年07月24日 14:22

故障说明

错误提示:The chosen operation is not currently available 

解决方案

步骤如下:

  1. 查看开发工具 Eclipse 版本,去 Eclipse 的安根目录找到 .eclipseproduct 打开查看 Eclipse 版本 

  2. 菜单 Help->Install New Software

  3. 点击 Available Software Sites00155b1a423dae0309ef55dd623758d

  4. 查看安装的 SDK 版本是否和 Eclipse 版本是否匹配,如果不匹配,请卸载掉,重新安装 SDK

  5. 参考如下

Eclipse 4.4 之前版本请使用以下链接:

https://download.oneapm.com/android_agent/eclipse_lt_4.4/

Eclipse 4.4 及之后版本请使用以下链接:

注:OneAPM Eclipse 4.4 插件需要 JDK 1.8。

https://download.oneapm.com/android_agent/eclipse_gt_4.4/

 


回复

cstslqq发表于 2015年11月10日 12:02

Eclipse 4.2,JDK 1.6,安装失败:The chosen operation is not currently available 

wanglulu发表于 2015年11月12日 15:58

我也是

张岩OneAPM发表于 2015年11月13日 16:14

各位好,这个问题是下载的版本不正确导致的,请参考这个文档来解决,少数情况下,Eclipse版本和ADT版本不匹配也可能导致这个问题,但解决问题的思路是一样的,即匹配对于的版本即可。

您需要登录后才可以回复